Connectivity Issues Affecting Swell-Hosted Checkout
Incident Report for Swell
Resolved
This incident has been resolved.
Posted Jan 07, 2025 - 07:55 PST
Monitoring
Services for the Swell-hosted checkout connected to our data centers are in the process of recovering. We will continue to monitor the situation closely to ensure full stability.
Posted Jan 07, 2025 - 07:08 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 07, 2025 - 06:01 PST
Identified
We are currently experiencing connectivity issues that may result in latency or timeout errors for our hosted checkout. This issue has been identified as originating from a third-party service provider. Our team is actively monitoring their progress and exploring potential mitigations to minimize the impact on our services.

We appreciate your patience and will provide updates as soon as new information becomes available.
Posted Jan 07, 2025 - 06:00 PST
This incident affected: Hosted Checkout.