The intermittent connectivity issues affecting users in the Paris, Ireland, and Frankfurt regions have been identified and resolved. Network performance has returned to normal. We appreciate your patience while we worked to address the problem.
Posted May 31, 2025 - 18:08 PDT
Update
We are continuing to investigate the intermittent connectivity issues. We’ve identified that the impact is primarily affecting users in regions around Paris, Ireland, and Frankfurt. Our team is actively working with our network partners to resolve the issue. We’ll share further updates as we learn more. Thank you for your continued patience.
Posted May 31, 2025 - 13:28 PDT
Update
We’re currently investigating reports of intermittent connectivity issues affecting users in certain regions. Our team is working to identify the cause and will provide updates as more information becomes available. Thank you for your patience.
Posted May 31, 2025 - 12:20 PDT
Investigating
The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.