Swell-hosted checkout load times
Incident Report for Swell
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 14:33 PST
Monitoring
We've identified and addressed an issue that was impacting the load time of Swell's hosted checkout. Following the application of a fix, it seems that the problem has been resolved. However, we'll be diligently monitoring the situation. If you encounter any persisting issues, please don't hesitate to contact Swell support for further assistance.
Posted Nov 14, 2023 - 11:37 PST