Admin dashboard: Slow response time
Incident Report for Swell
Resolved
This incident has been resolved.
Posted Nov 30, 2023 - 10:39 PST
Investigating
We are actively investigating reports indicating slower response times experienced within our admin dashboard.
Posted Nov 30, 2023 - 06:58 PST
This incident affected: Dashboard.