Long load times for admin dashboard
Incident Report for Swell
Resolved
We identified the cause for the degraded performance and have implemented a fix. Response time for the dashboard has recovered. This issue is now resolved.
Posted Jun 21, 2023 - 09:40 PDT
Investigating
We are currently investigating reports of long load times for the admin dashboard
Posted Jun 21, 2023 - 09:00 PDT
This incident affected: Dashboard.